iLO: Your browser must accept cookies

Les cartes iLO sont très pratiques et on les utilise parfois dans l’urgence quand quelque-chose se passe mal sur un serveur.

Mais les différentes mises à jour des navigateurs, dont certaines passent plus ou moins inaperçues, font qu’il est tout à coup impossible de les utiliser, c’est plutôt gênant pour un outil utilisé dans l’urgence. Ainsi avec Firefox il impossible d’utiliser la console virtuelle en ‘.NET’, il faut utiliser ‘Java Applet’ ou ‘Java Web start’, encore faut-il que Firefox n’ai pas décidé de bloquer la version de Java installée sur le poste de travail… J’ai abandonné l’idée d’utiliser ‘Microsoft Edge’ pour utiliser les cartes iLO, il est tout simplement impossible d’afficher la mire de connexion, probablement à cause des options SSL? C’est également vrai pour certains autres équipements (interfaces d’administration de PDU, d’équipements réseaux…

Tout à coup, même en utilisant ‘Internet Explorer’ il est impossible de se connecter aux cartes iLO, une fenêtre s’affiche ‘Your browser must accept cookies’.

Une rapide recherche sur Internet donne la réponse sur la page du support de HPE: HP Integrated Lights-Out – Unable to Connect to an iLO Interface Using Internet Explorer

It turned out that the issue was caused because the user had configured the IP addresses of iLO in their DNS Server with an Underscore (_) in their name. For example: server01_il0.domain.com.
The iLO UI was accessible if the iLO IP was used to access it and not its DNS name. The underscore was removed from one of the server’s DNS entry and the end-user was able to connect to the iLO using the DNS name as well.
When checked, it was confirmed that this behavior is by design from Internet Explorer. Accepting cookie with underscore in domain name is violation of RFC 1035.
Security patch MS01-055 prevents servers with improper name syntax from setting cookies names. Domains that use cookies must use only alphanumeric characters (« – » or « . ») in the domain name and the server name. Internet explorer blocks cookies from a server if the server name contains other characters, such as an underscore character (« _ »).”

Ce n’est donc pas un comportement nouveau, l’article de HP n’est pas daté (mais fais référence à IE8/IE9) et le patch de sécurité MS01-055 date de 2001! D’ailleurs j’avais déjà rencontré un problème similaire avec une application intranet chez un Client en 2002.

J’avais juste oublié ce détail concernant le ‘_’ quand j’ai complété et remis en forme le fichier ‘hosts’ sur mon poste de travail.

 

 

 

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.